Posts by Vethial

    Hi - My office recently moved to O365 and we also received some TLS security updates to our servers. I have several VBA Excel macros connecting to the server that are no longer working. I am now receiving Connection failed - SQL Server Error 772 - TCPIP Socket


    I have tried to change my code but still having issue. Any advise is appreciated.


    Original Code

    Worksheets("CALC_REF").Range("Z1") = "ODBC;Description=CI Dev Server;DRIVER=SQL Server;SERVER=DBVEPxxxxxxx;UID=" & USR & ";APP=Microsoft Data Access Components;WSID=" & WS & ""

    Hi - my macros are used across a company with about 200 people using them. Some have migrated to Office 365 , some have not. In windows 10 the code works as expected, only runs in the instance of excel you have the macro in and does not bleed to another file if you are multi tasking. In 365 it will start writing to any window/instance of excel you select.


    My code does identify the worksheet at the beginning of the code.

    Worksheets("XXX").Activate


    However after that identification of the sheet , my code simply says to copay and past to a column

    EX

    Range("A" & Activecell.row)= "XXX"

    Range("B" & Activecell.row)="BBB"

    Hi - I moved to office 365 today form Windows 10. Have a situation I am investigating.


    Issue

    1.User has multiple instances of excel open. One with a macro, one with other files.

    2.User selects macro button on a workbook to run and macro starts as expected. Macro in this instance is pulling data from a system and writing data to a worksheet on that macro workbook

    3.While macro is running – they select other excel window/instance to multi task and look at other workbooks/ files not related to macro

    4.Macro starts writing to the other excel window/instance and overlays what data is on their non macro file.


    What setting or alternative solution do I need to select/deselect to prevent the macro from bleeding into the other workbook and to keep macro to its dedicated workbook


    Thank you