Transpose function help required

  • Hello,


    In a workbook, i have a worksheet 'template' where the Parameters are Vertical and the Groups are horizontal, but in my 'raw data' worksheet it is quite opposite, Groups are vertical and parameters are horizontal.


    Please help me in finding out the Transpose function formula with which i can get the data into the template from the Raw data


    Sample file attached.


    Thanks.

  • Re: Transpose function help required


    If you remove the spaces in the column headers, this in C4 copied down and across


    =INDEX(Data!$B$4:$Q$8,MATCH(Template!C$2,Data!$A$4:$A$8,0),MATCH(Template!$B4,Data!$B$3:$Q$3,0))

  • Re: Transpose function help required


    Hi Stephen,


    Thank you so much, it is working like a charm for the sample Data, but the main data i have has spaces and ' - ' in between the text for both "Parameters" and "Groups".


    Request you to please tweek the formula to consider the spaces and "-" symbol between the text.

  • Re: Transpose function help required


    Maybe something like this..?


  • Re: Transpose function help required


    Hi Stephen,


    No, the data is dynamic. I will download the 'data' file everyday and will move the 'template' worksheet to the data file where the 'data' worksheet is present.


    Request you to please tweek the formula to consider the spaces and "-" symbol between the text.


    Hi Apo,


    Thanks for your code,


    But the Parameters (Parameter 1, Parameter 2..............Parameter 11) is sample text but the actual parameters contains space in between two words and also special charecter like '>' '=' '-' '()'. Code provided is not working. Please provide another code if possible.


    Updated sample file attached. This is the exaxt replica of my actual file but the text is sample and differs with the actual data.

  • Re: Transpose function help required


    Quote

    Code provided is not working. Please provide another code if possible.


    Did you try the file i attached.. ?


    The output i get when running it is the same as you show..


    Also.. I can't see any difference between your updated attachment and the original attachment..


    Perhaps attach a file that shows EXACT sample data and EXACT results.. otherwise.. we are all just guessing..