The Excel links between 2 files are lost after sending them to a new PC.

  • I have a spreed Sheet linked to another SS in a different Folder. In "My Computer" the linked Files work.... But If I send the ZIP (Folders and Files) to another computer the Folder Path Link gets Broken...

    In my Origin The Formula says: =PROCV($D12;'C:\Users\user1\Documents\foldername1\example.xlsm'!$B$8:$N$77;10;);)


    The path between the workbook and the lookup workbook is not the same on both computer. When I copy the File to another PC it's a different "user" so it doesn't work. How can I link them? What should I do?


    Onemore Info: THe Folder Tree is always the same in the folders:

    File 1= C:\Users\user1\Documents\foldername1\all.xls (Gets Info from File 2, 3 and 4)

    File 2=C:\Users\user1\Documents\foldername1\folder1\example1.xls

    File 3=C:\Users\user1\Documents\foldername1\folder2\example2.xls

    File 4=C:\Users\user1\Documents\foldername1\folder3\example3.xls


    Thank you in advance for your help!

  • This might help


    link management and storage in Excel


    Quote

    Relative vs. absolute links

    Links to external workbooks are created in a relative manner whenever possible. This means that the full path to the source data file is not recorded, but rather the portion of the path as it relates to the linked workbook. With this method, you can move the workbooks without breaking the links between them. The links remain intact, however, only if the workbooks remain in the same location relative to each other. For example, if the linked file is C:\Mydir\Linked.xls and the source data file is C:\Mydir\Files\Source.xls, you can move the files to the D drive as long as the source file is still located in a subfolder called "files".

    Relative links may cause problems if you move the linked file to different computers and the source is in a central location.

  • MODERATOR NOTICE: This topic has also been posted on other sites and may already have an answer elsewhere. Please take this into consideration when answering this question


    Again you have been reported for cross posting. Have you bothered reading the Forum Rules yet. Surely you must have noticed most Excel Forums have this rule and you will soon get known for cross posting and will find members will help!

  • Hi Roy.


    Your solution is not the answer.... I don't need to know Why :) .... I need a solution to get the link fixed, without changing every formula (Or Hyperlink).

    I need to know if there is another way to fix this....


    Thank you in advance for your help... (and about the forum and my misbehave so sorry.... still learning the way.... thank you for your help and comments).