Workbookopen () macro triggering twice

  • Hi Guys,


    I have a simple macro that opens and saves the file as the next running number in cell I3. It has been working for the past 3-4 months and suddenly 3-4 days ago, it just suddenly started to behave differently. Now whenever the file is open it opens 2 files. However when I already have excel opened in the background, it stops triggering twice and does it once like normal. I have not amended the macro in anyway 3-4 days ago and am really lost on why it suddenly started behaving like this and how do I return it to normal (by triggering just once)?


    Any help would be greatly appreciated.


    Sorry that I crossposted as i wasn't aware that excelforum.com and ozgrid.com is the same forum. My apologies for not putting the code with the

  • crosspost: https://www.excelforum.com/exc…cro-triggering-twice.html


    You have obviously not spent any time reading the forum rules that you agreed to as you have violated two of them.




    Your post does not comply with our Forum RULES. Use code tags around code.


    Posting code between

    Code

    tags makes your code much easier to read and copy for testing, it also maintains VBA formatting.


    Click on Edit to open your thread, then highlight your code and click the # icon at the top of your post window.



    Cross-posting is when you post the same question in other forums on the web. The last thing you want to do is waste people's time working on an issue you have already resolved elsewhere. We prefer that you not cross-post at all, but if you do (and it's unlikely to go unnoticed), you MUST provide a link (copy the url from the address bar in your browser) to the cross-post.


    Expect cross-posted questions without a link to be closed and a message will be posted by the moderator explaining why. We are here to help so help us to help you!


    Read this to understand why we ask you to do this, and then please edit your first post to include links to any and all cross-posts in any other forums (not just this site).


    Your post does not comply with our Forum RULES. Do not crosspost your question on multiple forums without including links here to the other threads on other forums.



    (This thread should receive no further responses until this moderation request is fulfilled)


  • Sorry that I crossposted as i wasn't aware that excelforum.com and ozgrid.com is the same forum. My apologies for not putting the code with the [CODE]. I hope that I have done it right this time. I have tried debugging it and been googling it for the past 2 days.


    We are not the same forum, we have members that use both forums. Your comment suggests you still do not understand why cross-posting is an issue. Make sure you read the link posted above by Alan.