Announcement

Collapse
No announcement yet.

Method or Data Member not found

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Method or Data Member not found



    I have been using a macro for a few months now and it has been working wonderfully. Now I deployed(network with about 10 people sharing) the sheet with the Macro and am getting a Compile error:
    "Method or Data Member not found"

    I just looked at the form in the editor and the Calendar is not showing up on the form, it has been there for the past month or so and now it is not there. My local copy of this file, the one that I copied to the network is still working fine. These have identical code.

    The code below is what the debugger is showing as the problem.

    Calendar1 is what is highlighted during debugging.

    Code:
    Private Sub UserForm_Activate()
        Me.Calendar1.Value = Date
    End Sub
    Any ideas on what I need to do?


    If I need to post the workbook please let me know and I will trim it up a little.


    Thanks in advance.

  • #2
    Re: Method or Data Member not found

    Hi Jefsboys,

    I had a similar problem and when I added the Calendar back into the Form, the problem was solved.

    Regards,

    Bill

    Comment


    • #3
      Re: Method or Data Member not found

      Hi j,

      You may find that some of the other users do not have the Calendar control available on their systems. (From memory, users who have Access installed will typically have the contol available). Check for any missing references.
      Cross-poster? Read this: Cross-posters
      Struggling to use tags (including Code tags)? : Forum tags

      Comment


      • #4
        Re: Method or Data Member not found

        Ranger and Richie,

        Thanks to both of you.

        Ranger,
        I put the Calendar back on there it appears to be working from the netork again. My worry is, am I going to have to continue doing this? Did you have to replace the calendar control more than once?

        I just had to add the calendar back to the form again. I am not sure what to do here.


        Richie,

        I have one user that does not have that object available on his machine(message says so when opening the file) he does not have Access installed on his machine. If you know would you share with me how I could install the calendar control on his machine, if it is not to lengthy.

        Could I replace the MSCAL.ocx file on his machine with mine. That is where my Calendar Control 9.0 is at.

        Once again a humungous thanks to both of you.

        Jeffrey

        Comment


        • #5
          Re: Method or Data Member not found

          Hi Jeffrey,

          The info here may prove useful:

          http://www.fontstuff.com/mailbag/qvba01.htm

          HTH
          Cross-poster? Read this: Cross-posters
          Struggling to use tags (including Code tags)? : Forum tags

          Comment


          • #6
            Re: Method or Data Member not found

            Hi Jefsboys,

            I did not have to replace the Calendar more than once.

            As far as the Calendar is concerned for the user that does not have Access, if you go into the VB Editor and Select the Toolbox Icon and right click the Toolbox which appears, then scroll down to Calendar Control

            Regards.

            Bill

            Comment


            • #7


              Re: Method or Data Member not found

              Bill and Richie,

              Thanks again.

              I went to the fontstuff website and got the needed controls installed on the computer. The location of mscal.ocx file was not where the webisite said it should be so I moved it and registered the control. Another computer had an older copy of the file so I updated that and his calendar control is popping up now also.

              I am not sure if the location is critical, but I did it anyway.

              I put a copy of the mscal.ocx file in my network folder. Excel not running and got the following;
              When I tried to move a copy of the file onto another users computer(system32 folder) I got a message stating that I couldn't move it because it was in use (it wasn't).
              Could I get this message if I don't have administrator privileges on that users computer?

              I greatly appreciate your guys time on the forum as should everyone else here.

              Thanks

              Comment

              Working...
              X