No announcement yet.

Macro is 'Unviewable'

  • Filter
  • Time
  • Show
Clear All
new posts

  • Macro is 'Unviewable'

    Excel 97 and I believe I created the Workbook using Excel 2000.
    I used File Save As in Excel 97 just to be sure.

    The workbook does not show as Read Only in it's Properties page.

    I open the workbook. I am prompted to Enable Macros and I select Enable.

    I hit the Run Macros button or Alt+F11 where I can view the attached macros but the Edit adn Step Into buttons are greyed out.

    I tried going in through Alt+F11 and Project Explorer and recieve the message that the macros are unviewable.

    Does anybody know why I can not view or edit ot step into the macros on this workbook and does anyone know if there is a way around it?

    Thanks in advance.
    Attached Files

  • #2

    See here for the bad news:
    Cross-poster? Read this: Cross-posters
    Struggling to use tags (including Code tags)? : Forum tags


    • #3

      you might want to see Tools>Protect>Protect and share workbook

      Remove protect and share workbook
      cuz, once you protect and share your workbook, then your vba code becomes
      unviewable which appears in a message box

      might help

      Your Help Is Highly Appreciated


      • #4

        sorry, i was misstaken

        here is the solution, if..................

        If you try to view a Visual Basic for Applications project in the Microsoft Visual Basic Editor, the following error message may appear

        Project Locked
        Project is unviewable
        even though you did not lock the project for viewing in the properties for the project. This message may also appear if you click VBAProject Properties on the Tools menu in the Microsoft Visual Basic Editor.

        This behavior occurs if you try to view a project that is in a shared workbook.

        You cannot view a project in a shared workbook. If you want to view a project in a shared workbook, turn off sharing. To turn off sharing, use the following steps:
        Open the shared workbook.
        On the Tools menu, click Share Workbook.
        Clear the Allow changes by more than one user at the same time check box, and then click OK.

        Your Help Is Highly Appreciated


        • #5

          Thank you Richie(UK) and Helmekki,

          The workbook was digitally signed by me on the Office 2K machine that I no longer have access to.

          The workbook was not set up as being a shared workbook.

          However, I did make it into a shared workbook. I received an error stating that I couldn't share it because it contained macros. Clicking the OK button saves the workbook anyway.
          I then removed the Share (that it alledgedly couldn't have) and sure enough I can View, Edit and Step into it's macros.

          Thank you very much.